wiki:epics/bbb/debian/cape/uartx1

Version 1 (modified by michkawa, 2 years ago) (diff)

--

RS232C x1 cape

以前作成したSerialx4 Boxの1ポート版。
以前基板は作ったけど、安く作成するためのケースが決まらなかったのと、Debian7になって独自に作成したcapeを自動で認識しなくなってしまったので放置してた。
Debian8になって、cape周りが改善された(?)ようなので再開することにした。

cape

以前作っておいたcapeのEEPROMに書き込んでおいたものがあったので、起動時に認識されているかを見てみた。

[    2.343774] bone_capemgr bone_capemgr: Baseboard: 'A335BNLT,00C0,3115BBBK0805'
[    2.343809] bone_capemgr bone_capemgr: compatible-baseboard=ti,beaglebone-black - #slots=4
[    2.382159] bone_capemgr bone_capemgr: slot #0: 'RS232C Tiny Cape,00A0,KEK cERL CTRL,cape-uart-tiny'
[    2.422019] bone_capemgr bone_capemgr: slot #1: No cape found
[    2.462015] bone_capemgr bone_capemgr: slot #2: No cape found
[    2.502015] bone_capemgr bone_capemgr: slot #3: No cape found
[    2.502280] bone_capemgr bone_capemgr: initialized OK.
[    2.504321] PM: bootloader does not support rtc-only!
[    2.505368] omap_rtc 44e3e000.rtc: setting system clock to 2000-01-01 00:00:00 UTC (946684800)
[    2.505400] of_cfs_init
[    2.505523] of_cfs_init: OK
[    2.511353] PM: Hibernation image not present or could not be loaded.
              :
[    3.514385] bone_capemgr bone_capemgr: loader: failed to load slot-0 cape-uart-tiny:00A0 (prio 0)

まだ、firmwareを入れてないので、認識はするけどその後エラーになっている。ここまでは以前と同じ。
firmwareをインストールして再度起動してみたけど、やはりダメだった。

firmwareの内容は以前とちょっと変わったので、修正してある。

/*
* Copyright (C) 2013-2017 Tetsuya Michikawa <hig-mchi@post.kek.jp>
*
*  BeagleBone Black UART 1,2 used RS232c cape
*/
/dts-v1/;
/plugin/;



/ {
        compatible = "ti,beaglebone", "ti,beaglebone-black", "ti,beaglebone-green";

        /* identification */
        /*part-number = "cape-bone-uart-tiny";*/
        part-number = "cape-uart-tiny";
        version = "00A0";

        /* state the resources this cape uses */
        exclusive-use =
                /* the pin header uses */
                "P9.24",        /* uart1_txd */
                "P9.26",        /* uart1_rxd */
                "P9.21",        /* uart2_txd */
                "P9.22",        /* uart2_rxd */
                /* the hardware ip uses */
                "uart1",
                "uart2";
        fragment@0 {
                target = <&am33xx_pinmux>;
                __overlay__ {
                        bb_uart1_pins: pinmux_bb_uart1_pins {
                                pinctrl-single,pins = <
                                        /*0x180 0x20*/ /* P9.26 uart1_rxd.uart1_rxd  INPUT  */
                                        /*0x184 0x20*/ /* P9.24 uart1_txd.uart1_txd  OUTPUT  */
                                        0x184   0     // uart1_txd.uart1_txd
                                        0x180  (1<<8)      // uart1_rxd.uart1_rxd
                                >;
                        };
                        bb_uart2_pins: pinmux_bb_uart2_pins {
                                pinctrl-single,pins = <
                                        /*0x150 0x21*/ /* P9.22 spi0_sclk.uart2_rxd | MODE1 */
                                        /*0x154 0x01*/ /* P9.21 spi0_d0.uart2_txd | MODE1 */
                                        0x154     1     // spi0_d0.uart2_txd
                                        0x150   ((1<<8) | 1)     // spi0_sclk.uart2_rxd
                                >;
                        };
                };
        };

        fragment@1 {
                target = <&uart1>;
                __overlay__ {
                        status = "okay";
                        pinctrl-names = "default";
                        pinctrl-0 = <&bb_uart1_pins>;
                };
        };
        fragment@2 {
                target = <&uart2>;
                __overlay__ {
                        status = "okay";
                        pinctrl-names = "default";
                        pinctrl-0 = <&bb_uart2_pins>;
                };
        };
};

起動後に手動でbone-capemgrに登録すれば認識はされるので、firmwareが間違っているわけでもなさそう。

root@beaglebone:~# echo cape-uart-tiny > /sys/devices/platform/bone_capemgr/slots
root@beaglebone:~# cat /sys/devices/platform/bone_capemgr/slots
 0: P-----  -1 RS232C Tiny Cape,00A0,KEK cERL CTRL,cape-uart-tiny
 1: PF----  -1
 2: PF----  -1
 3: PF----  -1
 4: P-O-L-   0 Override Board Name,00A0,Override Manuf,cape-uart-tiny

root@beaglebone:~# dmesg
            :
[  224.894311] bone_capemgr bone_capemgr: part_number 'cape-uart-tiny', version 'N/A'
[  224.894397] bone_capemgr bone_capemgr: slot #4: override
[  224.894439] bone_capemgr bone_capemgr: Using override eeprom data at slot 4
[  224.894488] bone_capemgr bone_capemgr: slot #4: 'Override Board Name,00A0,Override Manuf,cape-uart-tiny'
[  224.931576] 48022000.serial: ttyS1 at MMIO 0x48022000 (irq = 199, base_baud = 3000000) is a 8250
[  224.946064] 48024000.serial: ttyS2 at MMIO 0x48024000 (irq = 200, base_baud = 3000000) is a 8250
[  224.956129] bone_capemgr bone_capemgr: slot #4: dtbo 'cape-uart-tiny-00A0.dtbo' loaded; overlay id #0

以前は、ttyO1,ttyO2だったが、ttyS1,ttyS2に変わったみたい。

/boot/uEnv.txtを修正しても、結果は同じだった。

#enable_uboot_overlays=1
enable_uboot_overlays=1
#uboot_overlay_addr0=/lib/firmware/<file0>.dtbo
uboot_overlay_addr0=/lib/firmware/cape-uart-tiny-00A0.dtbo
###Custom Cape
dtb_overlay=/lib/firmware/cape-uart-tiny-00A0.dtbo
#disable_uboot_overlay_emmc=1
disable_uboot_overlay_video=1

#cmdline=coherent_pool=1M net.ifnames=0 quiet cape_universal=enable
cmdline=coherent_pool=1M net.ifnames=0 quiet cape_universal=disable

Attachments (2)

Download all attachments as: .zip